News feed is down
Incident Report for The Tie
Resolved
News system is caught up and functioning normally
Posted Apr 21, 2022 - 11:22 EDT
Identified
Our news system is temporarily backed up - should be resolved quickly
Posted Apr 21, 2022 - 11:14 EDT
This incident affected: API and SigDev Terminal.